MADCAP
MADCAP (Multicast Address Dynamic Client Allocation Protocol) and the MALLOC address-allocation architecture
Within this page
MADCAP RFCs (9)
RFC 10028: Updates to Dynamic IPv6 Multicast Address Group IDs
Proposed Standard- N. Karstens
- D. Farinacci
- M. McBride
- August 2026
- IETF publication
- Routing Area
Abstract
This document describes limitations of the existing range of dynamic IPv6 multicast addresses specified in "Allocation Guidelines for IPv6 Multicast Addresses" (RFC 3307). It updates RFC 3307 by replacing these allocations with a new IANA registry in the "IPv6 Multicast Address Space" registry group. The document also defines initial contents of the new registry: a reduced allocation for the Multicast Address Dynamic Client Allocation Protocol (MADCAP) (RFC 2730), a range for Source-Specific Multicast (SSM), a Private Use range, a range for Experimental Use, and Solicited-Node multicast addresses (which were not previously noted in RFC 3307).
Abstract
This document describes limitations of the existing range of dynamic IPv6 multicast addresses specified in "Allocation Guidelines for IPv6 Multicast Addresses" (RFC 3307). It updates RFC 3307 by replacing these allocations with a new IANA registry in the "IPv6 Multicast Address Space" registry group. The document also defines initial contents of the new registry: a reduced allocation for the Multicast Address Dynamic Client Allocation Protocol (MADCAP) (RFC 2730), a range for Source-Specific Multicast (SSM), a Private Use range, a range for Experimental Use, and Solicited-Node multicast addresses (which were not previously noted in RFC 3307).
RFC 10019: Zeroconf Multicast Address Allocation Problem Statement and Requirements
Informational- N. Karstens
- D. Farinacci
- M. McBride
- July 2026
- IETF publication
- Routing Area
Abstract
This document surveys current problems with existing protocols for automatically assigning multicast IP addresses in zero-configuration (zeroconf) networking environments. It addresses key challenges, such as link-layer address collisions, hardware limitations, multicast snooping inefficiencies, and the need to avoid manual configuration. Based on these challenges, it derives requirements for a lightweight, decentralized solution for dynamically allocating unique multicast group addresses without central coordination.
The document presents explicit requirements covering discovery, allocation, conflict detection and resolution, and lease management. It also evaluates considerations specific to IPv6 and IPv4 multicast address ranges, and identifies approaches that are unsuited for zeroconf deployment. This foundation serves as a reference for developing future solutions for multicast address allocation that operate autonomously within local networks.
Abstract
This document surveys current problems with existing protocols for automatically assigning multicast IP addresses in zero-configuration (zeroconf) networking environments. It addresses key challenges, such as link-layer address collisions, hardware limitations, multicast snooping inefficiencies, and the need to avoid manual configuration. Based on these challenges, it derives requirements for a lightweight, decentralized solution for dynamically allocating unique multicast group addresses without central coordination.
The document presents explicit requirements covering discovery, allocation, conflict detection and resolution, and lease management. It also evaluates considerations specific to IPv6 and IPv4 multicast address ranges, and identifies approaches that are unsuited for zeroconf deployment. This foundation serves as a reference for developing future solutions for multicast address allocation that operate autonomously within local networks.
RFC 3559: Multicast Address Allocation MIB
Proposed Standard- D. Thaler
- June 2003
- IETF publication
- Transport Area
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in the Internet community. In particular, it describes managed objects used for managing multicast address allocation. [STANDARDS-TRACK]
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in the Internet community. In particular, it describes managed objects used for managing multicast address allocation. [STANDARDS-TRACK]
RFC 3307: Allocation Guidelines for IPv6 Multicast Addresses
Proposed Standard- B. Haberman
- September 2002
- IETF publication
- Transport Area
Abstract
This document specifies guidelines that must be implemented by any
entity responsible for allocating IPv6 multicast addresses. This
includes, but is not limited to, any documents or entities wishing
to assign permanent IPv6 multicast addresses, allocate dynamic IPv6
multicast addresses, and define permanent IPv6 multicast group
identifiers. The purpose of these guidelines is to reduce the
probability of IPv6 multicast address collision, not only at the
IPv6 layer, but also at the link-layer of media that encode portions
of the IP layer address into the MAC layer address.
Abstract
This document specifies guidelines that must be implemented by any
entity responsible for allocating IPv6 multicast addresses. This
includes, but is not limited to, any documents or entities wishing
to assign permanent IPv6 multicast addresses, allocate dynamic IPv6
multicast addresses, and define permanent IPv6 multicast group
identifiers. The purpose of these guidelines is to reduce the
probability of IPv6 multicast address collision, not only at the
IPv6 layer, but also at the link-layer of media that encode portions
of the IP layer address into the MAC layer address.
RFC 2907: MADCAP Multicast Scope Nesting State Option
Proposed Standard- R. Kermode
- September 2000
- IETF publication
- Transport Area
Abstract
This document defines a new option to the Multicast Address Dynamic Client Allocation Protocol (MADCAP) to support nested scoping. [STANDARDS-TRACK]
Abstract
This document defines a new option to the Multicast Address Dynamic Client Allocation Protocol (MADCAP) to support nested scoping. [STANDARDS-TRACK]
RFC 2908: The Internet Multicast Address Allocation Architecture
Historic- D. Thaler
- M. Handley
- D. Estrin
- September 2000
- IETF publication
- Transport Area
Abstract
This document proposes a multicast address allocation architecture (MALLOC) for the Internet. This memo provides information for the Internet community.
- Obsoleted by RFC 6308
Abstract
This document proposes a multicast address allocation architecture (MALLOC) for the Internet. This memo provides information for the Internet community.
RFC 2909: The Multicast Address-Set Claim (MASC) Protocol
Historic- P. Radoslavov
- D. Estrin
- R. Govindan
- M. Handley
- S. Kumar
- D. Thaler
- September 2000
- IETF publication
- Transport Area
Abstract
This document describes the Multicast Address-Set Claim (MASC) protocol which can be used for inter-domain multicast address set allocation. This memo defines an Experimental Protocol for the Internet community.
Abstract
This document describes the Multicast Address-Set Claim (MASC) protocol which can be used for inter-domain multicast address set allocation. This memo defines an Experimental Protocol for the Internet community.
RFC 2771: An Abstract API for Multicast Address Allocation
Informational- R. Finlayson
- February 2000
- IETF publication
- Transport Area
Abstract
This document describes the "abstract service interface" for the dynamic multicast address allocation service, as seen by applications. This memo provides information for the Internet community.
Abstract
This document describes the "abstract service interface" for the dynamic multicast address allocation service, as seen by applications. This memo provides information for the Internet community.
RFC 2730: Multicast Address Dynamic Client Allocation Protocol (MADCAP)
Proposed Standard- S. Hanna
- B. Patel
- M. Shah
- December 1999
- IETF publication
- Transport Area
Abstract
This document defines a protocol, Multicast Address Dynamic Client Allocation Protocol (MADCAP), that allows hosts to request multicast addresses from multicast address allocation servers. [STANDARDS-TRACK]
Abstract
This document defines a protocol, Multicast Address Dynamic Client Allocation Protocol (MADCAP), that allows hosts to request multicast addresses from multicast address allocation servers. [STANDARDS-TRACK]
Subscribe to MADCAP
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.