SIP

SIP (Session Initiation Protocol): call signalling, extensions, deployment

SIP subjects:

SIP RFCs (300)

Display RFCs as
  • RFC 10006: Automatic SIP Trunking and Peering

    Proposed Standard
  • RFC 9996: Media Types for Protocol Buffers

    Informational
  • RFC 9878: Updates to Private Header (P-Header) Extension Usage in Session Initiation Protocol (SIP) Requests and Responses

    Informational
  • RFC 9796: SIP Call-Info Parameters for Rich Call Data

    Proposed Standard
  • RFC 9806: Updates to SIP-Based Media Recording (SIPREC) to Correct Metadata Media Type

    Proposed Standard
  • Informational
  • RFC 9366: Multiple SIP Reason Header Field Values

    Proposed Standard
  • RFC 9248: Interoperability Profile for Relay User Equipment

    Proposed Standard
  • RFC 9239: Updates to ECMAScript Media Types

    Informational
  • RFC 9071: RTP-Mixer Formatting of Multiparty Real-Time Text

    Proposed Standard
  • RFC 8866: SDP: Session Description Protocol

    Proposed Standard
  • RFC 8840: A Session Initiation Protocol (SIP) Usage for Incremental Provisioning of Candidates for the Interactive Connectivity Establishment (Trickle ICE)

    Proposed Standard
  • RFC 8844: Unknown Key-Share Attacks on Uses of TLS with the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 8850: Controlling Multiple Streams for Telepresence (CLUE) Protocol Data Channel

    Experimental
  • RFC 8862: BCP 228: Best Practices for Securing RTP Media Signaled with SIP

    Best Current Practice
  • RFC 8898: Third-Party Token-Based Authentication and Authorization for Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 8787: Location Source Parameter for the SIP Geolocation Header Field

    Proposed Standard
  • RFC 8760: The Session Initiation Protocol (SIP) Digest Access Authentication Scheme

    Proposed Standard
  • RFC 8643: An Opportunistic Approach for Secure Real-time Transport Protocol (OSRTP)

    Informational
  • RFC 8606: ISDN User Part (ISUP) Cause Location Parameter for the SIP Reason Header Field

    Proposed Standard
  • RFC 8599: Push Notification with the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 8591: SIP-Based Messaging with S/MIME

    Proposed Standard
  • RFC 8498: A P-Served-User Header Field Parameter for an Originating Call Diversion (CDIV) Session Case in the Session Initiation Protocol (SIP)

    Informational
  • RFC 8507: Simple Internet Protocol (SIP) Specification

    Historic
  • RFC 8497: Marking SIP Messages to Be Logged

    Proposed Standard
  • RFC 8496: P-Charge-Info: A Private Header Field (P-Header) Extension to the Session Initiation Protocol (SIP)

    Informational
  • RFC 8433: A Simpler Method for Resolving Alert-Info URNs

    Informational
  • RFC 8396: Managing, Ordering, Distributing, Exposing, and Registering Telephone Numbers (MODERN): Problem Statement, Use Cases, and Framework

    Informational
  • RFC 8373: Negotiating Human Language in Real-Time Communications

    Proposed Standard
  • RFC 8262: Content-ID Header Field in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 8255: Multiple Language Content Type

    Proposed Standard
  • RFC 8266: Preparation, Enforcement, and Comparison of Internationalized Strings Representing Nicknames

    Proposed Standard
  • RFC 8217: Clarifications for When to Use the name-addr Production in SIP Messages

    Proposed Standard
  • RFC 8197: A SIP Response Code for Unwanted Calls

    Proposed Standard
  • RFC 8101: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespace for Mission Critical Push To Talk Service

    Informational
  • RFC 8123: Requirements for Marking SIP Messages to be Logged

    Informational
  • RFC 8119: SIP "cause" URI Parameter for Service Number Translation

    Informational
  • RFC 8079: Guidelines for End-to-End Support of the RTP Control Protocol (RTCP) in Back-to-Back User Agents (B2BUAs)

    Proposed Standard
  • RFC 8055: Session Initiation Protocol (SIP) Via Header Field Parameter to Indicate Received Realm

    Proposed Standard
  • RFC 8048: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Presence

    Proposed Standard
  • RFC 7989: End-to-End Session Identification in IP-Based Multimedia Communication Networks

    Proposed Standard
  • RFC 7984: Locating Session Initiation Protocol (SIP) Servers in a Dual-Stack IP Network

    Proposed Standard
  • RFC 7976: Updates to Private Header (P-Header) Extension Usage in Session Initiation Protocol (SIP) Requests and Responses

    Informational

      Obsoleted by RFC 9878

  • RFC 7957: BCP 67: DISPATCH-Style Working Groups and the SIP Change Process

    Best Current Practice
  • RFC 7913: P-Access-Network-Info ABNF Update

    Informational
  • RFC 7879: DTLS-SRTP Handling in SIP Back-to-Back User Agents

    Proposed Standard
  • RFC 7700: Preparation, Enforcement, and Comparison of Internationalized Strings Representing Nicknames

    Proposed Standard

      Obsoleted by RFC 8266

  • RFC 7702: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Groupchat

    Proposed Standard
  • RFC 7647: Clarifications for the Use of REFER with RFC 6665

    Proposed Standard
  • RFC 7614: Explicit Subscriptions for the REFER Method

    Proposed Standard
  • RFC 7621: A Clarification on the Use of Globally Routable User Agent URIs (GRUUs) in the SIP Event Notification Framework

    Proposed Standard
  • RFC 7544: Mapping and Interworking of Diversion Information between Diversion and History-Info Header Fields in the Session Initiation Protocol (SIP)

    Informational
  • RFC 7584: Session Traversal Utilities for NAT (STUN) Message Handling for SIP Back-to-Back User Agents (B2BUAs)

    Proposed Standard
  • RFC 7572: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Instant Messaging

    Proposed Standard
  • RFC 7573: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): One-to-One Text Chat Sessions

    Proposed Standard
  • RFC 7549: 3GPP SIP URI Inter-Operator Traffic Leg Parameter

    Proposed Standard
  • RFC 7501: Terminology for Benchmarking Session Initiation Protocol (SIP) Devices: Basic Session Setup and Registration

    Informational
  • RFC 7502: Methodology for Benchmarking Session Initiation Protocol (SIP) Devices: Basic Session Setup and Registration

    Informational
  • RFC 7462: URNs for the Alert-Info Header Field of the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 7463: Shared Appearances of a Session Initiation Protocol (SIP) Address of Record (AOR)

    Proposed Standard
  • RFC 7415: Session Initiation Protocol (SIP) Rate Control

    Proposed Standard
  • RFC 7433: A Mechanism for Transporting User-to-User Call Control Information in SIP

    Proposed Standard
  • RFC 7434: Interworking ISDN Call Control User Information with SIP

    Proposed Standard
  • RFC 7403: A Media-Based Traceroute Function for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 7339: Session Initiation Protocol (SIP) Overload Control

    Proposed Standard
  • RFC 7355: Indicating WebSocket Protocol as a Transport in the Session Initiation Protocol (SIP) Common Log Format (CLF)

    Informational
  • RFC 7329: A Session Identifier for the Session Initiation Protocol (SIP)

    Informational

      Obsoleted by RFC 7989

  • RFC 7345: UDP Transport Layer (UDPTL) over Datagram Transport Layer Security (DTLS)

    Proposed Standard
  • RFC 7332: Loop Detection Mechanisms for Session Initiation Protocol (SIP) Back-to-Back User Agents (B2BUAs)

    Proposed Standard
  • RFC 7316: The Session Initiation Protocol (SIP) P-Private-Network-Indication Private Header (P-Header)

    Informational
  • RFC 7315: Private Header (P-Header) Extensions to the Session Initiation Protocol (SIP) for the 3GPP

    Informational
  • RFC 7247: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Architecture, Addresses, and Error Handling

    Proposed Standard
  • RFC 7248: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Presence

    Proposed Standard

      Obsoleted by RFC 8048

  • RFC 7255: Using the International Mobile station Equipment Identity (IMEI) Uniform Resource Name (URN) as an Instance ID

    Informational
  • RFC 7135: Registering a SIP Resource Priority Header Field Namespace for Local Emergency Communications

    Informational
  • RFC 7206: Requirements for an End-to-End Session Identification in IP-Based Multimedia Communication Networks

    Informational
  • RFC 7200: A Session Initiation Protocol (SIP) Load-Control Event Package

    Proposed Standard
  • RFC 7090: Public Safety Answering Point (PSAP) Callback

    Proposed Standard
  • RFC 7163: URN for Country-Specific Emergency Services

    Proposed Standard
  • RFC 7131: Session Initiation Protocol (SIP) History-Info Header Call Flow Examples

    Informational
  • RFC 7134: The Management Policy of the Resource Priority Header (RPH) Registry Changed to "IETF Review"

    Proposed Standard
  • RFC 7088: Session Initiation Protocol Service Example -- Music on Hold

    Informational
  • RFC 7044: An Extension to the Session Initiation Protocol (SIP) for Request History Information

    Proposed Standard
  • RFC 7118: The WebSocket Protocol as a Transport for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 7106: A Group Text Chat Purpose for Conference and Service URIs in the SIP Event Package for Conference State

    Informational
  • RFC 7092: A Taxonomy of Session Initiation Protocol (SIP) Back-to-Back User Agents

    Informational
  • RFC 7081: CUSAX: Combined Use of the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP)

    Informational
  • RFC 6993: Instant Messaging and Presence Purpose for the Call-Info Header Field in the Session Initiation Protocol (SIP)

    Informational
  • RFC 6910: Completion of Calls for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 6913: Indicating Fax over IP Capability in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 6881: BCP 181: Best Current Practice for Communications Services in Support of Emergency Calling

    Best Current Practice
  • RFC 6878: IANA Registry for the Session Initiation Protocol (SIP) "Priority" Header Field

    Proposed Standard
  • RFC 6872: The Common Log Format (CLF) for the Session Initiation Protocol (SIP): Framework and Information Model

    Proposed Standard
  • RFC 6873: Format for the Session Initiation Protocol (SIP) Common Log Format (CLF)

    Proposed Standard
  • RFC 6794: A Framework for Session Initiation Protocol (SIP) Session Policies

    Proposed Standard
  • RFC 6795: A Session Initiation Protocol (SIP) Event Package for Session-Specific Policies

    Proposed Standard
  • RFC 6796: A User Agent Profile Data Set for Media Policy

    Proposed Standard
  • RFC 6809: Mechanism to Indicate Support of Features and Capabilities in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 6665: SIP-Specific Event Notification

    Proposed Standard
  • RFC 6567: Problem Statement and Requirements for Transporting User-to-User Call Control Information in SIP

    Informational
  • RFC 6468: Sieve Notification Mechanism: SIP MESSAGE

    Proposed Standard
  • RFC 6446: Session Initiation Protocol (SIP) Event Notification Extension for Notification Rate Control

    Proposed Standard
  • RFC 6447: Filtering Location Notifications in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 6442: Location Conveyance for the Session Initiation Protocol

    Proposed Standard
  • RFC 6432: Carrying Q.850 Codes in Reason Header Fields in SIP (Session Initiation Protocol) Responses

    Proposed Standard
  • RFC 6357: Design Considerations for Session Initiation Protocol (SIP) Overload Control

    Informational
  • RFC 6337: Session Initiation Protocol (SIP) Usage of the Offer/Answer Model

    Informational
  • RFC 6314: NAT Traversal Practices for Client-Server SIP

    Informational
  • RFC 6228: Session Initiation Protocol (SIP) Response Code for Indication of Terminated Dialog

    Proposed Standard
  • RFC 6157: IPv6 Transition in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 6223: Indication of Support for Keep-Alive

    Proposed Standard
  • RFC 6193: Media Description for the Internet Key Exchange Protocol (IKE) in the Session Description Protocol (SDP)

    Informational
  • RFC 6216: Example Call Flows Using Session Initiation Protocol (SIP) Security Mechanisms

    Informational
  • RFC 6080: A Framework for Session Initiation Protocol User Agent Profile Delivery

    Proposed Standard
  • RFC 6140: Registration for Multiple Phone Numbers in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 6141: Re-INVITE and Target-Refresh Request Handling in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 6072: Certificate Management Service for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 6076: Basic Telephony SIP End-to-End Performance Metrics

    Proposed Standard
  • RFC 6086: Session Initiation Protocol (SIP) INFO Method and Package Framework

    Proposed Standard
  • RFC 6035: Session Initiation Protocol Event Package for Voice Quality Reporting

    Proposed Standard
  • RFC 6050: A Session Initiation Protocol (SIP) Extension for the Identification of Services

    Informational
  • RFC 6044: Mapping and Interworking of Diversion Information between Diversion and History-Info Headers in the Session Initiation Protocol (SIP)

    Informational

      Obsoleted by RFC 7544

  • RFC 5989: A SIP Event Package for Subscribing to Changes to an HTTP Resource

    Proposed Standard
  • RFC 6011: Session Initiation Protocol (SIP) User Agent Configuration

    Informational
  • RFC 6026: Correct Transaction Handling for 2xx Responses to Session Initiation Protocol (SIP) INVITE Requests

    Proposed Standard
  • RFC 5947: Requirements for Multiple Address of Record (AOR) Reachability Information in the Session Initiation Protocol (SIP)

    Informational
  • RFC 5954: Essential Correction for IPv6 ABNF and URI Comparison in RFC 3261

    Proposed Standard
  • RFC 5898: Connectivity Preconditions for Session Description Protocol (SDP) Media Streams

    Proposed Standard
  • RFC 5922: Domain Certificates in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5923: Connection Reuse in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5924: Extended Key Usage (EKU) for Session Initiation Protocol (SIP) X.509 Certificates

    Experimental
  • RFC 5888: The Session Description Protocol (SDP) Grouping Framework

    Proposed Standard
  • RFC 5897: Identification of Communications Services in the Session Initiation Protocol (SIP)

    Informational
  • RFC 5850: A Call Control and Multi-Party Usage Framework for the Session Initiation Protocol (SIP)

    Informational
  • RFC 5875: An Extensible Markup Language (XML) Configuration Access Protocol (XCAP) Diff Event Package

    Proposed Standard
  • RFC 5866: Diameter Quality-of-Service Application

    Proposed Standard
  • RFC 5763: Framework for Establishing a Secure Real-time Transport Protocol (SRTP) Security Context Using Datagram Transport Layer Security (DTLS)

    Proposed Standard
  • RFC 5839: An Extension to Session Initiation Protocol (SIP) Events for Conditional Event Notification

    Proposed Standard
  • RFC 5767: User-Agent-Driven Privacy Mechanism for SIP

    Informational
  • RFC 5768: Indicating Support for Interactive Connectivity Establishment (ICE) in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5853: Requirements from Session Initiation Protocol (SIP) Session Border Control (SBC) Deployments

    Informational
  • RFC 5876: Updates to Asserted Identity in the Session Initiation Protocol (SIP)

    Informational
  • RFC 5806: Diversion Indication in SIP

    Historic
  • RFC 5727: BCP 67: Change Process for the Session Initiation Protocol (SIP) and the Real-time Applications and Infrastructure Area

    Best Current Practice
  • RFC 5379: Guidelines for Using the Privacy Mechanism for SIP

    Informational
  • RFC 5688: A Session Initiation Protocol (SIP) Media Feature Tag for MIME Application Subtypes

    Proposed Standard
  • RFC 5626: Managing Client-Initiated Connections in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5627: Obtaining and Using Globally Routable User Agent URIs (GRUUs) in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5628: Registration Event Package Extension for Session Initiation Protocol (SIP) Globally Routable User Agent URIs (GRUUs)

    Proposed Standard
  • RFC 5629: A Framework for Application Interaction in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5630: The Use of the SIPS URI Scheme in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5631: Session Initiation Protocol (SIP) Session Mobility

    Informational
  • RFC 5658: Addressing Record-Route Issues in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5638: Simple SIP Usage Scenario for Applications in the Endpoints

    Informational
  • RFC 5621: Message Body Handling in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5616: Streaming Internet Messaging Attachments

    Informational
  • RFC 5606: Implications of 'retransmission-allowed' for SIP Location Conveyance

    Informational
  • RFC 5589: BCP 149: Session Initiation Protocol (SIP) Call Control - Transfer

    Best Current Practice
  • RFC 5552: SIP Interface to VoiceXML Media Services

    Proposed Standard
  • RFC 5502: The SIP P-Served-User Private-Header (P-Header) for the 3GPP IP Multimedia (IM) Core Network (CN) Subsystem

    Informational
  • RFC 5479: Requirements and Analysis of Media Security Management Protocols

    Informational
  • RFC 5509: Internet Assigned Numbers Authority (IANA) Registration of Instant Messaging and Presence DNS SRV RRs for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5503: Private Session Initiation Protocol (SIP) Proxy-to-Proxy Extensions for Supporting the PacketCable Distributed Call Signaling Architecture

    Informational
  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

    Proposed Standard
  • RFC 5411: A Hitchhiker's Guide to the Session Initiation Protocol (SIP)

    Informational
  • RFC 5393: Addressing an Amplification Vulnerability in Session Initiation Protocol (SIP) Forking Proxies

    Proposed Standard
  • RFC 5407: BCP 147: Example Call Flows of Race Conditions in the Session Initiation Protocol (SIP)

    Best Current Practice
  • RFC 5390: Requirements for Management of Overload in the Session Initiation Protocol

    Informational
  • RFC 5318: The Session Initiation Protocol (SIP) P-Refused-URI-List Private-Header (P-Header)

    Informational
  • RFC 5373: Requesting Answering Modes for the Session Initiation Protocol (SIP)

    Proposed Standard
  • Proposed Standard
  • Proposed Standard
  • RFC 5362: The Session Initiation Protocol (SIP) Pending Additions Event Package

    Proposed Standard
  • RFC 5363: Framework and Security Considerations for Session Initiation Protocol (SIP) URI-List Services

    Proposed Standard
  • RFC 5364: Extensible Markup Language (XML) Format Extension for Representing Copy Control Attributes in Resource Lists

    Proposed Standard
  • RFC 5365: Multiple-Recipient MESSAGE Requests in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5366: Conference Establishment Using Request-Contained Lists in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5367: Subscriptions to Request-Contained Resource Lists in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5368: Referring to Multiple Resources in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5369: Framework for Transcoding with the Session Initiation Protocol (SIP)

    Informational
  • RFC 5370: The Session Initiation Protocol (SIP) Conference Bridge Transcoding Model

    Proposed Standard
  • RFC 5359: BCP 144: Session Initiation Protocol Service Examples

    Best Current Practice
  • RFC 5278: IANA Registration of Enumservices for Voice and Video Messaging

    Proposed Standard
  • RFC 5194: Framework for Real-Time Text over IP Using the Session Initiation Protocol (SIP)

    Informational
  • RFC 5090: RADIUS Extension for Digest Authentication

    Proposed Standard
  • RFC 5118: Session Initiation Protocol (SIP) Torture Test Messages for Internet Protocol Version 6 (IPv6)

    Informational
  • RFC 5039: The Session Initiation Protocol (SIP) and Spam

    Informational
  • RFC 5079: Rejecting Anonymous Requests in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5057: Multiple Dialog Usages in the Session Initiation Protocol

    Informational
  • RFC 5009: Private Header (P-Header) Extension to the Session Initiation Protocol (SIP) for Authorization of Early Media

    Informational
  • RFC 5022: Media Server Control Markup Language (MSCML) and Protocol

    Informational
  • RFC 4964: The P-Answer-State Header Extension to the Session Initiation Protocol for the Open Mobile Alliance Push to Talk over Cellular

    Informational
  • RFC 5002: The Session Initiation Protocol (SIP) P-Profile-Key Private Header (P-Header)

    Informational
  • RFC 4967: Dial String Parameter for the Session Initiation Protocol Uniform Resource Identifier

    Proposed Standard
  • RFC 4916: Connected Identity in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 4904: Representing Trunk Groups in tel/sip Uniform Resource Identifiers (URIs)

    Proposed Standard
  • RFC 4780: Management Information Base for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 4787: BCP 127: Network Address Translation (NAT) Behavioral Requirements for Unicast UDP

    Best Current Practice
  • RFC 4769: IANA Registration for an Enumservice Containing Public Switched Telephone Network (PSTN) Signaling Information

    Proposed Standard
  • RFC 4740: Diameter Session Initiation Protocol (SIP) Application

    Proposed Standard
  • RFC 4722: Media Server Control Markup Language (MSCML) and Protocol

    Informational

      Obsoleted by RFC 5022

  • RFC 4730: A Session Initiation Protocol (SIP) Event Package for Key Press Stimulus (KPML)

    Proposed Standard
  • RFC 4474: Enhancements for Authenticated Identity Management in the Session Initiation Protocol (SIP)

    Proposed Standard

      Obsoleted by RFC 8224

  • RFC 4484: Trait-Based Authorization Requirements for the Session Initiation Protocol (SIP)

    Informational
  • RFC 4575: A Session Initiation Protocol (SIP) Event Package for Conference State

    Proposed Standard
  • RFC 4579: BCP 119: Session Initiation Protocol (SIP) Call Control - Conferencing for User Agents

    Best Current Practice
  • RFC 4596: Guidelines for Usage of the Session Initiation Protocol (SIP) Caller Preferences Extension

    Informational
  • RFC 4569: Internet Assigned Number Authority (IANA) Registration of the Message Media Feature Tag

    Informational
  • RFC 4590: RADIUS Extension for Digest Authentication

    Proposed Standard

      Obsoleted by RFC 5090

  • RFC 4538: Request Authorization through Dialog Identification in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 4483: A Mechanism for Content Indirection in Session Initiation Protocol (SIP) Messages

    Proposed Standard
  • RFC 4485: Guidelines for Authors of Extensions to the Session Initiation Protocol (SIP)

    Informational
  • RFC 4508: Conveying Feature Tags with the Session Initiation Protocol (SIP) REFER Method

    Proposed Standard
  • RFC 4504: SIP Telephony Device Requirements and Configuration

    Informational
  • RFC 4475: Session Initiation Protocol (SIP) Torture Test Messages

    Informational
  • RFC 4488: Suppression of Session Initiation Protocol (SIP) REFER Method Implicit Subscription

    Proposed Standard
  • RFC 4497: BCP 117: Interworking between the Session Initiation Protocol (SIP) and QSIG

    Best Current Practice
  • RFC 4457: The Session Initiation Protocol (SIP) P-User-Database Private-Header (P-Header)

    Informational
  • Informational
  • RFC 4458: Session Initiation Protocol (SIP) URIs for Applications such as Voicemail and Interactive Voice Response (IVR)

    Informational
  • RFC 4411: Extending the Session Initiation Protocol (SIP) Reason Header for Preemption Events

    Proposed Standard
  • RFC 4412: Communications Resource Priority for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 4353: A Framework for Conferencing with the Session Initiation Protocol (SIP)

    Informational
  • RFC 4320: Actions Addressing Identified Issues with the Session Initiation Protocol's (SIP) Non-INVITE Transaction

    Proposed Standard
  • RFC 4321: Problems Identified Associated with the Session Initiation Protocol's (SIP) Non-INVITE Transaction

    Informational
  • RFC 4354: A Session Initiation Protocol (SIP) Event Package and Data Format for Various Settings in Support for the Push-to-Talk over Cellular (PoC) Service

    Informational
  • RFC 4240: Basic Network Media Services with SIP

    Informational
  • RFC 4235: An INVITE-Initiated Dialog Event Package for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 4245: High-Level Requirements for Tightly Coupled SIP Conferencing

    Informational
  • RFC 4244: An Extension to the Session Initiation Protocol (SIP) for Request History Information

    Proposed Standard

      Obsoleted by RFC 7044

  • RFC 4189: Requirements for End-to-Middle Security for the Session Initiation Protocol (SIP)

    Informational
  • RFC 4168: The Stream Control Transmission Protocol (SCTP) as a Transport for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 4123: Session Initiation Protocol (SIP)-H.323 Interworking Requirements

    Informational
  • RFC 4117: Transcoding Services Invocation in the Session Initiation Protocol (SIP) Using Third Party Call Control (3pcc)

    Informational
  • RFC 4092: Usage of the Session Description Protocol (SDP) Alternative Network Address Types (ANAT) Semantics in the Session Initiation Protocol (SIP)

    Proposed Standard

      Obsoleted by RFC 5245

  • RFC 4083: Input 3rd-Generation Partnership Project (3GPP) Release 5 Requirements on the Session Initiation Protocol (SIP)

    Informational
  • RFC 4028: Session Timers in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 4032: Update to the Session Initiation Protocol (SIP) Preconditions Framework

    Proposed Standard
  • RFC 3976: Interworking SIP and Intelligent Network (IN) Applications

    Informational
  • RFC 3959: The Early Session Disposition Type for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3960: Early Media and Ringing Tone Generation in the Session Initiation Protocol (SIP)

    Informational
  • RFC 3968: BCP 98: The Internet Assigned Number Authority (IANA) Header Field Parameter Registry for the Session Initiation Protocol (SIP)

    Best Current Practice
  • RFC 3969: BCP 99: The Internet Assigned Number Authority (IANA) Uniform Resource Identifier (URI) Parameter Registry for the Session Initiation Protocol (SIP)

    Best Current Practice
  • RFC 3944: H.350 Directory Services

    Informational
  • RFC 3903: Session Initiation Protocol (SIP) Extension for Event State Publication

    Proposed Standard
  • RFC 3911: The Session Initiation Protocol (SIP) "Join" Header

    Proposed Standard
  • RFC 3910: The SPIRITS (Services in PSTN requesting Internet Services) Protocol

    Proposed Standard
  • RFC 3891: The Session Initiation Protocol (SIP) "Replaces" Header

    Proposed Standard
  • RFC 3892: The Session Initiation Protocol (SIP) Referred-By Mechanism

    Proposed Standard
  • RFC 3893: Session Initiation Protocol (SIP) Authenticated Identity Body (AIB) Format

    Proposed Standard
  • RFC 3840: Indicating User Agent Capabilities in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3841: Caller Preferences for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3842: A Message Summary and Message Waiting Indication Event Package for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3853: S/MIME Advanced Encryption Standard (AES) Requirement for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3824: Using E.164 numbers with the Session Initiation Protocol (SIP)

    Informational
  • RFC 3764: enumservice registration for Session Initiation Protocol (SIP) Addresses-of-Record

    Proposed Standard
  • RFC 3725: BCP 85: Best Current Practices for Third Party Call Control (3pcc) in the Session Initiation Protocol (SIP)

    Best Current Practice
  • RFC 3680: A Session Initiation Protocol (SIP) Event Package for Registrations

    Proposed Standard
  • RFC 3702: Authentication, Authorization, and Accounting Requirements for the Session Initiation Protocol (SIP)

    Informational
  • RFC 3665: BCP 75: Session Initiation Protocol (SIP) Basic Call Flow Examples

    Best Current Practice
  • RFC 3666: BCP 76: Session Initiation Protocol (SIP) Public Switched Telephone Network (PSTN) Call Flows

    Best Current Practice
  • RFC 3603: Private Session Initiation Protocol (SIP) Proxy-to-Proxy Extensions for Supporting the PacketCable Distributed Call Signaling Architecture

    Informational

      Obsoleted by RFC 5503

  • RFC 3608: Session Initiation Protocol (SIP) Extension Header Field for Service Route Discovery During Registration

    Proposed Standard
  • RFC 3581: An Extension to the Session Initiation Protocol (SIP) for Symmetric Response Routing

    Proposed Standard
  • RFC 3578: Mapping of Integrated Services Digital Network (ISDN) User Part (ISUP) Overlap Signalling to the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3319: Dynamic Host Configuration Protocol (DHCPv6) Options for Session Initiation Protocol (SIP) Servers

    Proposed Standard
  • RFC 3515: The Session Initiation Protocol (SIP) Refer Method

    Proposed Standard
  • RFC 3487: Requirements for Resource Priority Mechanisms for the Session Initiation Protocol (SIP)

    Informational
  • RFC 3486: Compressing the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3313: Private Session Initiation Protocol (SIP) Extensions for Media Authorization

    Informational
  • RFC 3455: Private Header (P-Header) Extensions to the Session Initiation Protocol (SIP) for the 3rd-Generation Partnership Project (3GPP)

    Informational

      Obsoleted by RFC 7315

  • RFC 3329: Security Mechanism Agreement for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3427: Change Process for the Session Initiation Protocol (SIP)

    Best Current Practice

      Obsoleted by RFC 5727

  • RFC 3327: Session Initiation Protocol (SIP) Extension Header Field for Registering Non-Adjacent Contacts

    Proposed Standard
  • RFC 3326: The Reason Header Field for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3398: Integrated Services Digital Network (ISDN) User Part (ISUP) to Session Initiation Protocol (SIP) Mapping

    Proposed Standard
  • RFC 3428: Session Initiation Protocol (SIP) Extension for Instant Messaging

    Proposed Standard
  • RFC 3323: A Privacy Mechanism for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3324: Short Term Requirements for Network Asserted Identity

    Informational
  • RFC 3325: Private Extensions to the Session Initiation Protocol (SIP) for Asserted Identity within Trusted Networks

    Informational
  • RFC 3420: Internet Media Type message/sipfrag

    Proposed Standard
  • RFC 3312: Integration of Resource Management and Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3311: The Session Initiation Protocol (SIP) UPDATE Method

    Proposed Standard
  • RFC 3310: Hypertext Transfer Protocol (HTTP) Digest Authentication Using Authentication and Key Agreement (AKA)

    Informational
  • RFC 3372: BCP 63: Session Initiation Protocol for Telephones (SIP-T): Context and Architectures

    Best Current Practice
  • RFC 3361: Dynamic Host Configuration Protocol (DHCP-for-IPv4) Option for Session Initiation Protocol (SIP) Servers

    Proposed Standard
  • RFC 3351: User Requirements for the Session Initiation Protocol (SIP) in Support of Deaf, Hard of Hearing and Speech-impaired Individuals

    Informational
  • RFC 3261: SIP: Session Initiation Protocol

    Proposed Standard
  • RFC 3262: Reliability of Provisional Responses in Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3263: Session Initiation Protocol (SIP): Locating SIP Servers

    Proposed Standard
  • RFC 3265: Session Initiation Protocol (SIP)-Specific Event Notification

    Proposed Standard

      Obsoleted by RFC 6665

  • RFC 3204: MIME media types for ISUP and QSIG Objects

    Proposed Standard
  • RFC 3087: Control of Service Context using SIP Request-URI

    Informational
  • RFC 3050: Common Gateway Interface for SIP

    Informational
  • RFC 2976: The SIP INFO Method

    Proposed Standard

      Obsoleted by RFC 6086

  • RFC 2848: The PINT Service Protocol: Extensions to SIP and SDP for IP Access to Telephone Call Services

    Proposed Standard
  • RFC 2543: SIP: Session Initiation Protocol

    Proposed Standard

      Obsoleted by RFC 3261, RFC 3262, RFC 3263, RFC 3264, RFC 3265

  • RFC 1694: Definitions of Managed Objects for SMDS Interfaces using SMIv2

    Draft Standard
  • RFC 1454: Comparison of Proposals for Next Version of IP

    Informational
  • RFC 1304: Definitions of Managed Objects for the SIP Interface Type

    Proposed Standard

      Obsoleted by RFC 1694

Subscribe to SIP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.