traceroute

Traceroute and path discovery tools

traceroute RFCs (19)

Display RFCs as
  • RFC 9961: MPLS Segment Routing Point-to-Multipoint (P2MP) Policy Ping

    Proposed Standard
  • RFC 9716: Mechanisms for MPLS Ping and Traceroute Procedures in Inter-Domain Segment Routing Networks

    Proposed Standard
  • RFC 9703: Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) Egress Peer Engineering (EPE) Segment Identifiers (SIDs) with MPLS Data Plane

    Proposed Standard
  • RFC 9655: Egress Validation in Label Switched Path Ping and Traceroute Mechanisms

    Proposed Standard
  • RFC 9507: Information-Centric Networking (ICN) Traceroute Protocol Specification

    Experimental
  • Proposed Standard
  • RFC 8487: Mtrace Version 2: Traceroute Facility for IP Multicast

    Proposed Standard
  • RFC 8287: Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs) with MPLS Data Planes

    Proposed Standard
  • RFC 7737: Label Switched Path (LSP) Ping and Traceroute Reply Mode Simplification

    Proposed Standard
  • RFC 7403: A Media-Based Traceroute Function for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 6791: Stateless Source Address Mapping for ICMPv6 Packets

    Proposed Standard
  • RFC 5508: BCP 148: NAT Behavioral Requirements for ICMP

    Best Current Practice
  • RFC 5388: Information Model and XML Data Model for Traceroute Measurements

    Proposed Standard
  • RFC 4560: Definitions of Managed Objects for Remote Ping, Traceroute, and Lookup Operations

    Proposed Standard
  • RFC 3609: Tracing Requirements for Generic Tunnels

    Informational
  • RFC 2925: Definitions of Managed Objects for Remote Ping, Traceroute, and Lookup Operations

    Proposed Standard

      Obsoleted by RFC 4560

  • RFC 1739: A Primer On Internet and TCP/IP Tools

    Informational

      Obsoleted by RFC 2151

  • RFC 1574: Essential Tools for the OSI Internet

    Informational
  • RFC 1393: Traceroute Using an IP Option

    Historic

      Obsoleted by RFC 6814

Subscribe to traceroute

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.