URI

URIs (Uniform Resource Identifiers): syntax, schemes, resolution, templates

URI subjects:

URI RFCs (138)

Display RFCs as
  • Proposed Standard
  • RFC 9758: Updates to the 'ipn' URI Scheme

    Proposed Standard
  • RFC 9734: X.509 Certificate Extended Key Usage (EKU) for Instant Messaging URIs

    Proposed Standard
  • RFC 9231: Additional XML Security Uniform Resource Identifiers (URIs)

    Proposed Standard
  • RFC 9246: URI Signing for Content Delivery Network Interconnection (CDNI)

    Proposed Standard
  • RFC 9038: Extensible Provisioning Protocol (EPP) Unhandled Namespaces

    Proposed Standard
  • RFC 8959: The "secret-token" URI Scheme

    Informational
  • RFC 8958: BCP 65: Updated Registration Rules for URI.ARPA

    Best Current Practice
  • RFC 8905: The 'payto' URI Scheme for Payments

    Informational
  • RFC 8820: BCP 190: URI Design and Ownership

    Best Current Practice
  • RFC 8657: Certification Authority Authorization (CAA) Record Extensions for Account URI and Automatic Certificate Management Environment (ACME) Method Binding

    Proposed Standard
  • RFC 8589: The 'leaptofrogans' URI Scheme

    Informational
  • RFC 8615: Well-Known Uniform Resource Identifiers (URIs)

    Proposed Standard
  • Informational
  • RFC 8307: Well-Known URIs for the WebSocket Protocol

    Proposed Standard
  • RFC 8124: The Session Description Protocol (SDP) WebSocket Connection URI Attribute

    Proposed Standard
  • RFC 8119: SIP "cause" URI Parameter for Service Number Translation

    Informational
  • RFC 8089: The "file" URI Scheme

    Proposed Standard
  • RFC 7869: The "vnc" URI Scheme

    Informational
  • RFC 7566: Enumservice Registration for 'acct' URI

    Experimental
  • RFC 7553: The Uniform Resource Identifier (URI) DNS Resource Record

    Informational
  • RFC 7565: The 'acct' URI Scheme

    Proposed Standard
  • RFC 7549: 3GPP SIP URI Inter-Operator Traffic Leg Parameter

    Proposed Standard
  • RFC 7512: The PKCS #11 URI Scheme

    Proposed Standard
  • RFC 7472: Internet Printing Protocol (IPP) over HTTPS Transport Binding and the 'ipps' URI Scheme

    Proposed Standard
  • RFC 7320: URI Design and Ownership

    Best Current Practice

      Obsoleted by RFC 8820

  • RFC 7284: The Profile URI Registry

    Informational
  • RFC 7106: A Group Text Chat Purpose for Conference and Service URIs in the SIP Event Package for Conference State

    Informational
  • RFC 7111: URI Fragment Identifiers for the text/csv Media Type

    Informational
  • RFC 7064: URI Scheme for the Session Traversal Utilities for NAT (STUN) Protocol

    Proposed Standard
  • RFC 7065: Traversal Using Relays around NAT (TURN) Uniform Resource Identifiers

    Proposed Standard
  • RFC 6920: Naming Things with Hashes

    Proposed Standard
  • RFC 6931: Additional XML Security Uniform Resource Identifiers (URIs)

    Proposed Standard

      Obsoleted by RFC 9231

  • RFC 6910: Completion of Calls for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 6874: Representing IPv6 Zone Identifiers in Address Literals and Uniform Resource Identifiers

    Proposed Standard

      Obsoleted by RFC 9844

  • RFC 6694: The "about" URI Scheme

    Informational
  • RFC 6415: Web Host Metadata

    Proposed Standard
  • RFC 6270: The 'tn3270' URI Scheme

    Proposed Standard
  • RFC 6207: The Media Types application/mods+xml, application/mads+xml, application/mets+xml, application/marcxml+xml, and application/sru+xml

    Informational
  • RFC 6196: Moving mailserver: URI Scheme to Historic

    Proposed Standard
  • RFC 6116: The E.164 to Uniform Resource Identifiers (URI) Dynamic Delegation Discovery System (DDDS) Application (ENUM)

    Proposed Standard
  • RFC 5986: Discovering the Local Location Information Server (LIS)

    Proposed Standard
  • RFC 5954: Essential Correction for IPv6 ABNF and URI Comparison in RFC 3261

    Proposed Standard
  • RFC 5870: A Uniform Resource Identifier for Geographic Locations ('geo' URI)

    Proposed Standard
  • RFC 5538: The 'news' and 'nntp' URI Schemes

    Proposed Standard
  • RFC 5785: Defining Well-Known Uniform Resource Identifiers (URIs)

    Proposed Standard

      Obsoleted by RFC 8615

  • RFC 5781: The rsync URI Scheme

    Informational
  • RFC 5724: URI Scheme for Global System for Mobile Communications (GSM) Short Message Service (SMS)

    Proposed Standard
  • RFC 5630: The Use of the SIPS URI Scheme in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5582: Location-to-URL Mapping Architecture and Framework

    Informational
  • RFC 5593: Internet Message Access Protocol (IMAP) - URL Access Identifier Extension

    Proposed Standard
  • RFC 5526: The E.164 to Uniform Resource Identifiers (URI) Dynamic Delegation Discovery System (DDDS) Application for Infrastructure ENUM

    Informational
  • RFC 5318: The Session Initiation Protocol (SIP) P-Refused-URI-List Private-Header (P-Header)

    Informational
  • RFC 5363: Framework and Security Considerations for Session Initiation Protocol (SIP) URI-List Services

    Proposed Standard
  • RFC 5365: Multiple-Recipient MESSAGE Requests in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5366: Conference Establishment Using Request-Contained Lists in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5341: The Internet Assigned Number Authority (IANA) tel Uniform Resource Identifier (URI) Parameter Registry

    Proposed Standard
  • RFC 5147: URI Fragment Identifiers for the text/plain Media Type

    Proposed Standard
  • RFC 5092: IMAP URL Scheme

    Proposed Standard
  • RFC 5028: A Telephone Number Mapping (ENUM) Service Registration for Instant Messaging (IM) Services

    Proposed Standard
  • RFC 5017: MIB Textual Conventions for Uniform Resource Identifiers (URIs)

    Proposed Standard
  • RFC 4967: Dial String Parameter for the Session Initiation Protocol Uniform Resource Identifier

    Proposed Standard
  • RFC 4904: Representing Trunk Groups in tel/sip Uniform Resource Identifiers (URIs)

    Proposed Standard
  • RFC 4759: The ENUM Dip Indicator Parameter for the "tel" URI

    Proposed Standard
  • RFC 4769: IANA Registration for an Enumservice Containing Public Switched Telephone Network (PSTN) Signaling Information

    Proposed Standard
  • RFC 4715: The Integrated Services Digital Network (ISDN) Subaddress Encoding Type for tel URI

    Informational
  • RFC 4694: Number Portability Parameters for the "tel" URI

    Proposed Standard
  • RFC 4575: A Session Initiation Protocol (SIP) Event Package for Conference State

    Proposed Standard
  • RFC 4510: Lightweight Directory Access Protocol (LDAP): Technical Specification Road Map

    Proposed Standard
  • RFC 4516: Lightweight Directory Access Protocol (LDAP): Uniform Resource Locator

    Proposed Standard
  • RFC 4467: Internet Message Access Protocol (IMAP) - URLAUTH Extension

    Proposed Standard
  • RFC 4501: Domain Name System Uniform Resource Identifiers

    Proposed Standard
  • RFC 4452: The "info" URI Scheme for Information Assets with Identifiers in Public Namespaces

    Informational
  • RFC 4415: IANA Registration for Enumservice Voice

    Proposed Standard
  • RFC 4395: Guidelines and Registration Procedures for New URI Schemes

    Best Current Practice

      Obsoleted by RFC 7595

  • RFC 4266: The gopher URI Scheme

    Proposed Standard
  • RFC 4248: The telnet URI Scheme

    Proposed Standard
  • RFC 4151: The 'tag' URI Scheme

    Informational
  • RFC 4156: The wais URI Scheme

    Historic
  • RFC 4157: The prospero URI Scheme

    Historic
  • RFC 4088: Uniform Resource Identifier (URI) Scheme for the Simple Network Management Protocol (SNMP)

    Proposed Standard
  • RFC 4095: Attaching Meaning to Solicitation Class Keywords

    Proposed Standard
  • RFC 4078: The TV-Anytime Content Reference Identifier (CRID)

    Informational
  • RFC 4051: Additional XML Security Uniform Resource Identifiers (URIs)

    Proposed Standard

      Obsoleted by RFC 6931

  • RFC 4002: IANA Registration for Enumservice 'web' and 'ft'

    Proposed Standard
  • RFC 3986: STD 66: Uniform Resource Identifier (URI): Generic Syntax

    Internet Standard
  • RFC 3953: Telephone Number Mapping (ENUM) Service Registration for Presence Services

    Proposed Standard
  • RFC 3969: BCP 99: The Internet Assigned Number Authority (IANA) Uniform Resource Identifier (URI) Parameter Registry for the Session Initiation Protocol (SIP)

    Best Current Practice
  • RFC 3966: The tel URI for Telephone Numbers

    Proposed Standard
  • RFC 3841: Caller Preferences for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3861: Address Resolution for Instant Messaging and Presence

    Proposed Standard
  • RFC 3761: The E.164 to Uniform Resource Identifiers (URI) Dynamic Delegation Discovery System (DDDS) Application (ENUM)

    Proposed Standard

      Obsoleted by RFC 6116, RFC 6117

  • RFC 3617: Uniform Resource Identifier (URI) Scheme and Applicability Statement for the Trivial File Transfer Protocol (TFTP)

    Informational
  • RFC 3508: H.323 Uniform Resource Locator (URL) Scheme Registration

    Informational
  • RFC 3510: Internet Printing Protocol/1.1: IPP URL Scheme

    Proposed Standard
  • RFC 3421: Select and Sort Extensions for the Service Location Protocol (SLP)

    Experimental
  • RFC 3367: Common Name Resolution Protocol (CNRP)

    Proposed Standard
  • RFC 3368: The 'go' URI Scheme for the Common Name Resolution Protocol

    Proposed Standard
  • RFC 3087: Control of Service Context using SIP Request-URI

    Informational
  • RFC 2972: Context and Goals for Common Name Resolution

    Informational
  • RFC 2838: Uniform Resource Identifiers for Television Broadcasts

    Informational
  • RFC 2806: URLs for Telephone Calls

    Proposed Standard

      Obsoleted by RFC 3966

  • RFC 2732: Format for Literal IPv6 Addresses in URL's

    Proposed Standard

      Obsoleted by RFC 3986

  • RFC 2717: Registration Procedures for URL Scheme Names

    Best Current Practice

      Obsoleted by RFC 4395

  • RFC 2718: Guidelines for new URL Schemes

    Informational

      Obsoleted by RFC 4395

  • RFC 2609: Service Templates and Service: Schemes

    Proposed Standard
  • RFC 2557: MIME Encapsulation of Aggregate Documents, such as HTML (MHTML)

    Proposed Standard
  • RFC 2384: POP URL Scheme

    Proposed Standard
  • RFC 2392: Content-ID and Message-ID Uniform Resource Locators

    Proposed Standard
  • RFC 2396: Uniform Resource Identifiers (URI): Generic Syntax

    Draft Standard

      Obsoleted by RFC 3986

  • RFC 2397: The "data" URL scheme

    Proposed Standard
  • RFC 2368: The mailto URL scheme

    Proposed Standard

      Obsoleted by RFC 6068

  • RFC 2369: The Use of URLs as Meta-Syntax for Core Mail List Commands and their Transport through Message Header Fields

    Proposed Standard
  • RFC 2345: Domain Names and Company Name Retrieval

    Experimental
  • RFC 2295: Transparent Content Negotiation in HTTP

    Experimental
  • RFC 2296: HTTP Remote Variant Selection Algorithm -- RVSA/1.0

    Historic
  • RFC 2255: The LDAP URL Format

    Proposed Standard

      Obsoleted by RFC 4510, RFC 4516

  • RFC 2244: ACAP -- Application Configuration Access Protocol

    Proposed Standard
  • RFC 2224: NFS URL Scheme

    Informational
  • RFC 2187: Application of Internet Cache Protocol (ICP), version 2

    Informational
  • RFC 2192: IMAP URL Scheme

    Proposed Standard

      Obsoleted by RFC 5092

  • RFC 2111: Content-ID and Message-ID Uniform Resource Locators

    Proposed Standard

      Obsoleted by RFC 2392

  • RFC 2122: VEMMI URL Specification

    Proposed Standard
  • RFC 2079: Definition of an X.500 Attribute Type and an Object Class to Hold Uniform Resource Identifiers (URIs)

    Proposed Standard
  • RFC 2056: Uniform Resource Locators for Z39.50

    Proposed Standard
  • RFC 2016: Uniform Resource Agents (URAs)

    Experimental
  • RFC 2017: Definition of the URL MIME External-Body Access-Type

    Proposed Standard
  • RFC 1980: A Proposed Extension to HTML : Client-Side Image Maps

    Historic

      Obsoleted by RFC 2854

  • RFC 1959: An LDAP URL Format

    Proposed Standard

      Obsoleted by RFC 2255

  • RFC 1808: Relative Uniform Resource Locators

    Proposed Standard

      Obsoleted by RFC 3986

  • RFC 1736: Functional Recommendations for Internet Resource Locators

    Informational
  • RFC 1727: A Vision of an Integrated Internet Information Service

    Informational
  • RFC 1728: Resource Transponders

    Informational
  • RFC 1729: Using the Z39.50 Information Retrieval Protocol

    Informational
  • RFC 1738: Uniform Resource Locators (URL)

    Proposed Standard

      Obsoleted by RFC 4248, RFC 4266

  • RFC 1625: WAIS over Z39.50-1988

    Informational
  • RFC 1630: Universal Resource Identifiers in WWW: A Unifying Syntax for the Expression of Names and Addresses of Objects on the Network as used in the World-Wide Web

    Informational
  • RFC 1635: FYI 24: How to Use Anonymous FTP

    Informational

Subscribe to URI

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.