Lightweight Directory Access Protocol (LDAP): Authentication Methods and Security Mechanisms
draft-ietf-ldapbis-authmeth-19
Revision differences
Document history
| Date | Rev. | By | Action |
|---|---|---|---|
|
2012-08-22
|
19 | (System) | post-migration administrative database adjustment to the Yes position for Sam Hartman |
|
2012-08-22
|
19 | (System) | post-migration administrative database adjustment to the No Objection position for Brian Carpenter |
|
2012-08-22
|
19 | (System) | post-migration administrative database adjustment to the No Objection position for Russ Housley |
|
2006-02-22
|
19 | Amy Vezza | State Changes to RFC Ed Queue from Approved-announcement sent by Amy Vezza |
|
2006-02-17
|
19 | Amy Vezza | IESG state changed to Approved-announcement sent |
|
2006-02-17
|
19 | Amy Vezza | IESG has approved the document |
|
2006-02-17
|
19 | Amy Vezza | Closed "Approve" ballot |
|
2006-02-16
|
19 | Ted Hardie | State Changes to Approved-announcement to be sent from IESG Evaluation::AD Followup by Ted Hardie |
|
2006-02-16
|
19 | Russ Housley | [Ballot Position Update] Position for Russ Housley has been changed to No Objection from Discuss by Russ Housley |
|
2006-02-15
|
19 | Sam Hartman | [Ballot Position Update] Position for Sam Hartman has been changed to Yes from Discuss by Sam Hartman |
|
2006-02-14
|
19 | Brian Carpenter | [Ballot Position Update] Position for Brian Carpenter has been changed to No Objection from Discuss by Brian Carpenter |
|
2006-02-13
|
19 | Russ Housley | [Ballot comment] Please reference RFC 4346 instead of draft-ietf-tls-rfc2246-bis. |
|
2006-02-13
|
19 | Russ Housley | [Ballot discuss] Please add a brief discussion of client certificate identity handling to the paragraph that talks about client authentication in section 6.2. … [Ballot discuss] Please add a brief discussion of client certificate identity handling to the paragraph that talks about client authentication in section 6.2. If the client provides a valid user certificate, what might cause the implementation to reject the TLS negotiation? |
|
2006-02-13
|
19 | (System) | Sub state has been changed to AD Follow up from New Id Needed |
|
2006-02-13
|
19 | (System) | New version available: draft-ietf-ldapbis-authmeth-19.txt |
|
2006-02-03
|
19 | (System) | Removed from agenda for telechat - 2006-02-02 |
|
2006-02-02
|
19 | Amy Vezza | State Changes to IESG Evaluation::Revised ID Needed from IESG Evaluation by Amy Vezza |
|
2006-02-02
|
19 | (System) | [Ballot Position Update] New position, No Objection, has been recorded for Alex Zinin by IESG Secretary |
|
2006-02-02
|
19 | Allison Mankin | [Ballot Position Update] New position, No Objection, has been recorded for Allison Mankin by Allison Mankin |
|
2006-02-02
|
19 | Bill Fenner | [Ballot Position Update] New position, No Objection, has been recorded for Bill Fenner by Bill Fenner |
|
2006-02-01
|
19 | Bert Wijnen | [Ballot Position Update] New position, No Objection, has been recorded for Bert Wijnen by Bert Wijnen |
|
2006-02-01
|
19 | David Kessens | [Ballot Position Update] New position, No Objection, has been recorded for David Kessens by David Kessens |
|
2006-02-01
|
19 | Michelle Cotton | IANA Comments: Upon approval of this document the IANA will update the reference to be this document in the ldap-parameters registry for the StartTLS (1.3.6.1.4.1.1466.20037) … IANA Comments: Upon approval of this document the IANA will update the reference to be this document in the ldap-parameters registry for the StartTLS (1.3.6.1.4.1.1466.20037) extended operation. This update will take place in the following registry: http://www.iana.org/assignments/ldap-parameters |
|
2006-01-31
|
19 | Scott Hollenbeck | [Ballot Position Update] New position, No Objection, has been recorded for Scott Hollenbeck by Scott Hollenbeck |
|
2006-01-31
|
19 | Sam Hartman | [Ballot discuss] Can a client depend on being able to query the supported mechanisms attributed after authentication to see if the list was modified by … [Ballot discuss] Can a client depend on being able to query the supported mechanisms attributed after authentication to see if the list was modified by an attacker? If not, please document the possibility of a downgrade attack in the security considerations section. If so, please explicitly note this. Section 5 implies that a sasl security layer can be removed. This is inconsistent with current thinking in the SASL working group. Please remove this implication. |
|
2006-01-31
|
19 | Sam Hartman | [Ballot comment] Please consider removing the reference to RFC 2401 or 4301 from this document's discussion of SASL external. I don't think that IPsec implementations … [Ballot comment] Please consider removing the reference to RFC 2401 or 4301 from this document's discussion of SASL external. I don't think that IPsec implementations tend to provide the identity information that SASL external would need and so I believe this reference is at best misleading. |
|
2006-01-31
|
19 | Sam Hartman | [Ballot Position Update] New position, Discuss, has been recorded for Sam Hartman by Sam Hartman |
|
2006-01-29
|
19 | Russ Housley | [Ballot comment] Please reference RFC 4301 instead of RFC 2401. Please reference RFC 4346 instead of draft-ietf-tls-rfc2246-bis. Please change "IPSec" to "IPsec." |
|
2006-01-29
|
19 | Russ Housley | [Ballot discuss] Please include the fact that this document will Obsolete RFCs 2251, 2829, and 2830 in the Abstract. I am surprised by … [Ballot discuss] Please include the fact that this document will Obsolete RFCs 2251, 2829, and 2830 in the Abstract. I am surprised by the selection of TLS_DHE_DSS_WITH_3DES_EDE_CBC_SHA as the mandatory-to-implement TLS ciphersuite. TLS 1.1 (RFC 4346) requires TLS_RSA_WITH_3DES_EDE_CBC_SHA. Section 3.3 says: > > Ciphersuites vulnerable to man-in-the-middle attacks SHOULD NOT be > used to protect passwords or sensitive data, unless the network > configuration is such that the danger of a man-in-the-middle > attack is tolerable. > I am concerned with the very subjective nature of "tolerable." Some people can tolerate more pain than others. Please change this to "negligible." This term, while still subjective, has a more appropriate connotation. Please add a brief discussion of client certificate identity handling to the paragraph that talks about client authentication in section 6.2. If the client provides a valid user certificate, what might cause the implementation to reject the TLS negotiation? |
|
2006-01-29
|
19 | Russ Housley | [Ballot Position Update] New position, Discuss, has been recorded for Russ Housley by Russ Housley |
|
2006-01-27
|
19 | Brian Carpenter | [Ballot comment] Non-blocking comments are in Gen-ART review at http://www.alvestrand.no/ietf/gen/reviews/draft-ietf-ldapbis-authmeth-18-dawkins.txt |
|
2006-01-27
|
19 | Brian Carpenter | [Ballot discuss] (raised by Spencer Dawkins in Gen-ART review) 6.2. StartTLS Security Considerations Clients SHOULD by default either warn the user when the security … [Ballot discuss] (raised by Spencer Dawkins in Gen-ART review) 6.2. StartTLS Security Considerations Clients SHOULD by default either warn the user when the security level achieved does not provide an acceptable level of data confidentiality and/or data integrity protection, or be configured to refuse to proceed without an acceptable level of security. It seemed odd that this is a SHOULD (when is it appropriate to continue with unacceptable confidentiality/integrity protection without either warning the user or refusing to proceed?). |
|
2006-01-27
|
19 | Brian Carpenter | [Ballot Position Update] New position, Discuss, has been recorded for Brian Carpenter by Brian Carpenter |
|
2006-01-24
|
19 | Ted Hardie | Placed on agenda for telechat - 2006-02-02 by Ted Hardie |
|
2006-01-24
|
19 | Ted Hardie | State Changes to IESG Evaluation from Waiting for Writeup by Ted Hardie |
|
2006-01-24
|
19 | Ted Hardie | [Ballot Position Update] New position, Yes, has been recorded for Ted Hardie |
|
2006-01-24
|
19 | Ted Hardie | Ballot has been issued by Ted Hardie |
|
2006-01-24
|
19 | Ted Hardie | Created "Approve" ballot |
|
2006-01-20
|
19 | (System) | State has been changed to Waiting for Writeup from In Last Call by system |
|
2006-01-06
|
19 | Amy Vezza | Last call sent |
|
2006-01-06
|
19 | Amy Vezza | State Changes to In Last Call from Last Call Requested by Amy Vezza |
|
2006-01-06
|
19 | Ted Hardie | State Changes to Last Call Requested from Publication Requested by Ted Hardie |
|
2006-01-06
|
19 | Ted Hardie | Last Call was requested by Ted Hardie |
|
2006-01-06
|
19 | (System) | Ballot writeup text was added |
|
2006-01-06
|
19 | (System) | Last call text was added |
|
2006-01-06
|
19 | (System) | Ballot approval text was added |
|
2005-12-07
|
19 | Ted Hardie | State Changes to Publication Requested from AD is watching by Ted Hardie |
|
2005-12-07
|
19 | Ted Hardie | Intended Status has been changed to Proposed Standard from None |
|
2005-11-21
|
18 | (System) | New version available: draft-ietf-ldapbis-authmeth-18.txt |
|
2005-10-25
|
17 | (System) | New version available: draft-ietf-ldapbis-authmeth-17.txt |
|
2005-10-14
|
16 | (System) | New version available: draft-ietf-ldapbis-authmeth-16.txt |
|
2005-08-17
|
15 | (System) | New version available: draft-ietf-ldapbis-authmeth-15.txt |
|
2005-02-14
|
14 | (System) | New version available: draft-ietf-ldapbis-authmeth-14.txt |
|
2004-10-26
|
13 | (System) | New version available: draft-ietf-ldapbis-authmeth-13.txt |
|
2004-08-20
|
12 | (System) | New version available: draft-ietf-ldapbis-authmeth-12.txt |
|
2004-08-03
|
19 | Ted Hardie | Security review requested for -12 version, once available. |
|
2004-07-21
|
11 | (System) | New version available: draft-ietf-ldapbis-authmeth-11.txt |
|
2004-02-17
|
10 | (System) | New version available: draft-ietf-ldapbis-authmeth-10.txt |
|
2003-12-11
|
09 | (System) | New version available: draft-ietf-ldapbis-authmeth-09.txt |
|
2003-10-27
|
08 | (System) | New version available: draft-ietf-ldapbis-authmeth-08.txt |
|
2003-10-09
|
07 | (System) | New version available: draft-ietf-ldapbis-authmeth-07.txt |
|
2003-07-15
|
19 | Ted Hardie | Draft Added by Hardie, Ted |
|
2003-07-03
|
06 | (System) | New version available: draft-ietf-ldapbis-authmeth-06.txt |
|
2003-03-06
|
05 | (System) | New version available: draft-ietf-ldapbis-authmeth-05.txt |
|
2002-11-06
|
04 | (System) | New version available: draft-ietf-ldapbis-authmeth-04.txt |
|
2002-03-06
|
03 | (System) | New version available: draft-ietf-ldapbis-authmeth-03.txt |
|
2001-11-20
|
02 | (System) | New version available: draft-ietf-ldapbis-authmeth-02.txt |
|
2001-07-25
|
01 | (System) | New version available: draft-ietf-ldapbis-authmeth-01.txt |
|
2001-02-21
|
00 | (System) | New version available: draft-ietf-ldapbis-authmeth-00.txt |