[android][image-picker] fix inconsistent naming of filesize property (filesize vs fileSize) #27293
Add this suggestion to a batch that can be applied as a single commit.
This suggestion is invalid because no changes were made to the code.
Suggestions cannot be applied while the pull request is closed.
Suggestions cannot be applied while viewing a subset of changes.
Only one suggestion per line can be applied in a batch.
Add this suggestion to a batch that can be applied as a single commit.
Applying suggestions on deleted lines is not supported.
You must change the existing code in this line in order to create a valid suggestion.
Outdated suggestions cannot be applied.
This suggestion has been applied or marked resolved.
Suggestions cannot be applied from pending reviews.
Suggestions cannot be applied on multi-line comments.
Suggestions cannot be applied while the pull request is queued to merge.
Suggestion cannot be applied right now. Please check back later.
rename filesize to fileSize.
Android Implementation was different from iOS, ts definitions (ImagePicker.types.ts) & docu.
This was probably not intended and a bug
Why
The naming of filesize was different on iOS (fileSize) and Android (filesize).
This PR should unify the naming.
Support for fileSize in Android was added in #24524 but this improves the naming to make it the same on iOS & Android.
Naming:
filesize: Android
fileSize: iOS, typescript, docs
How
Replace in Files "filesize" -> "fileSize" in the whole packages/expo-image-picker/android folder.
Test Plan
I did not test this feature.
This change is fairly simple.
But consumer that rely on the "wrong" field name might get a breaking change if this bug is fixed
Checklist
npx expo prebuild
& EAS Build (eg: updated a module plugin).