Replies: 9 comments 6 replies
-
|
Replace |
Beta Was this translation helpful? Give feedback.
-
|
From @ghiggi: For AreaDefinition, many methods are not clear if they return data in xy or lat/lon; the pixel centroid or the outermost pixel corner. Maybe would be worth adding a common suffix (i.e. _ll) when they return lat/lons, and otherwise expect they return xy coords. This will enhance code readability.
|
Beta Was this translation helpful? Give feedback.
-
|
From @ghiggi: Add utility properties like |
Beta Was this translation helpful? Give feedback.
-
|
From @ghiggi: Add |
Beta Was this translation helpful? Give feedback.
-
|
From @ghiggi: Current
|
Beta Was this translation helpful? Give feedback.
-
|
From @ghiggi: For GEO AreaDef, all the above _ll methods currently return np.nan/np.inf values. Maybe ad-hoc processing using get_geostationary_bounding_box_in_lonlats could be implemented for area_extent_ll, but the corners would remain undefined ! Maybe would be worth raising an error to avoid downstream bugs ! |
Beta Was this translation helpful? Give feedback.
-
|
Deprecate/remove |
Beta Was this translation helpful? Give feedback.
-
|
An additional note to For In the Maybe an option could be to return the |
Beta Was this translation helpful? Give feedback.
-
|
What about no BaseDefinition class? Besides isinstance checks which should probably use duck typing instead, do we need it? I think we could just design things by "composition". That is, build up the functionality in separate and specific helper classes. |
Beta Was this translation helpful? Give feedback.
Uh oh!
There was an error while loading. Please reload this page.
Uh oh!
There was an error while loading. Please reload this page.
-
While working on #464 it was realized that there isn't a Pyresample 2.0 issue specifically for how/where AreaDefinition's should change. I think this is primarily missing because we didn't have great ideas for how much we wanted to break backwards compatibility. This is a discussion topic meant to be a place for brainstorming ideas and getting feedback. I don't use GitHub Discussions very much, but I was thinking we could try to do main comments for ideas and then sub-comments for feedback of those ideas. I'll try to copy feedback from #464 and other places.
Note: #464 already includes removing
area_id,proj_id, anddescriptionas required arguments in favor of aattrsmetadata dictionary.Beta Was this translation helpful? Give feedback.
All reactions