Ping and Windows shutdown from Synology NAS on Docker #235
|
I'm having a couple of issues when running Homebridge-WOL from a Docker container on my Synology NAS. The first one is that for whatever reason, the ping command is unable to execute; from the Terminal I get an error: I'm guessing that there's something I need to do to set the ping command SetUID or the like, but I'm not particularly versed in Docker. The CLI The other issue that's even more puzzling is that my Windows machine is unable to shut down. When I try shutting down from HomeKit, no error appears in the Homebridge log. If I issue the same shutdown command from the Homebridge terminal, it works fine; I see: and the machine shuts down pretty much right away, as expected. I'm guessing that the execution path seen by the terminal is different than that seen by the Homebridge parent process. I tried configuring the plugin to use the full path to the Has anyone managed to get this working on a Synology under Docker? |
Replies: 2 comments
|
Okay, I figured out that I'm still at a loss for why |
|
Now it seems to be working for shutdown as well. I have no idea what changed. I wish I could post a more satisfying resolution for anyone else searching for this issue. |
Now it seems to be working for shutdown as well. I have no idea what changed. I wish I could post a more satisfying resolution for anyone else searching for this issue.