Replies: 1 comment 1 reply
|
hi @yaskoo, sorry for the late answer, I missed your question. Ontop doesn't support Apache Impala, so in principle a new DB adapter would have to be implemented: https://ontop-vkg.org/dev/db-adapter.html In the Impala dialect is close enough to MySQL, as a hack, you may try adding the following entries to your properties file: com.cloudera.impala.jdbc41.Driver-serializer = it.unibz.inf.ontop.generation.serializer.impl.MySQLSelectFromWhereSerializer
com.cloudera.impala.jdbc41.Driver-normalizer = it.unibz.inf.ontop.generation.normalization.impl.MySQLExtraNormalizer
com.cloudera.impala.jdbc41.Driver-typeFactory = it.unibz.inf.ontop.model.type.impl.MySQLDBTypeFactory
com.cloudera.impala.jdbc41.Driver-symbolFactory = it.unibz.inf.ontop.model.term.functionsymbol.db.impl.MySQLDBFunctionSymbolFactory
com.cloudera.impala.jdbc41.Driver-metadataProvider = it.unibz.inf.ontop.dbschema.impl.MySQLDBMetadataProvider |
1 reply
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Uh oh!
There was an error while loading. Please reload this page.
Uh oh!
There was an error while loading. Please reload this page.
Using a GraphDB Ontop (ontop version 5.1.0) repository, I'm trying to connect to Apache Impala. Impala is a service provided by Cloudera. The driver I'm using is this. Connection is successful, but complex queries fail with syntax errors, specifically:
Similar to MySQL and MariaDB, Impala expects backticks and not double quotes.
Is there a way to work around this problem?
All reactions