In #10380, we renamed the url and ca portions of x-pack feature's elasticsearch configs to hosts and certificate_authority respectively to align with naming across the stack for 7.0.
While these were soft-deprecated with helpful messaging in 6.7, a user who attempts to upgrade to 7.x without passing through 6.7 (which is unadvised, but will happen) will encounter the following unhelpful error message and exit:
[2019-03-29T19:00:47,648][FATAL][logstash.runner ] An unexpected error occurred! {:error=>#<ArgumentError: Setting "xpack.monitoring.elasticsearch.url" hasn't been registered>, :backtrace=>[REDACTED]}
[2019-03-29T19:00:47,732][ERROR][org.logstash.Logstash ] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit
Ideally, we should reintroduce url and ca to 7.0 and 7.x as hard-deprecations that still cause the service to fail to start, but with a more helpful error message.
In #10380, we renamed the
urlandcaportions of x-pack feature's elasticsearch configs tohostsandcertificate_authorityrespectively to align with naming across the stack for 7.0.While these were soft-deprecated with helpful messaging in 6.7, a user who attempts to upgrade to 7.x without passing through 6.7 (which is unadvised, but will happen) will encounter the following unhelpful error message and exit:
Ideally, we should reintroduce
urlandcato7.0and7.xas hard-deprecations that still cause the service to fail to start, but with a more helpful error message.