Skip to content

Rename of config params for x-pack in 7.x produces unhelpful error message #10616

Description

@yaauie

In #10380, we renamed the url and ca portions of x-pack feature's elasticsearch configs to hosts and certificate_authority respectively to align with naming across the stack for 7.0.

While these were soft-deprecated with helpful messaging in 6.7, a user who attempts to upgrade to 7.x without passing through 6.7 (which is unadvised, but will happen) will encounter the following unhelpful error message and exit:

[2019-03-29T19:00:47,648][FATAL][logstash.runner          ] An unexpected error occurred! {:error=>#<ArgumentError: Setting "xpack.monitoring.elasticsearch.url" hasn't been registered>, :backtrace=>[REDACTED]}
[2019-03-29T19:00:47,732][ERROR][org.logstash.Logstash    ] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Ideally, we should reintroduce url and ca to 7.0 and 7.x as hard-deprecations that still cause the service to fail to start, but with a more helpful error message.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions