Skip to content

Error: listen EADDRNOTAVAIL when starting hapi server with foreman #409

Description

@toddhickerson

hapi is unable to start up when using foreman. It is unable to use the port that foreman starts up when accessed by process.env.PORT.

var server = new Hapi.Server(process.env.PORT);

Since this is the only way to deploy to heroku.com, this is important to get working.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

Labels

non issueIssue is not a problem or requires changes

Type

No type

Projects

No projects

    Milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions