https://github.com/lxc/lxc/blob/main/config/init/common/lxc-containers.in#L90 causes the script to ignore the exit code of lxc-autostart and always returns 0. Since at least Ubuntu/Debian distros use this script in /usr/lib/systemd/system/lxc.service to auto start lxc-zones, this results in systemctl status lxc reporting success, even if autostarting containers [partially] failed. As a consequence, failures during container autostart may go unnoticed by the service manager and by monitoring systems relying on the unit's exit status.
https://github.com/lxc/lxc/blob/main/config/init/common/lxc-containers.in#L90 causes the script to ignore the exit code of
lxc-autostartand always returns0. Since at least Ubuntu/Debian distros use this script in/usr/lib/systemd/system/lxc.serviceto auto start lxc-zones, this results insystemctl status lxcreporting success, even if autostarting containers [partially] failed. As a consequence, failures during container autostart may go unnoticed by the service manager and by monitoring systems relying on the unit's exit status.