Skip to content

Tags: zendesk/mail

Tags

2.7.0

Toggle 2.7.0's commit message
Mail 2.7.0

Features:
* mikel#647 – IMAP: specify IMAP server search charset with Mail.find(search_charset: 'UTF-8'). (yalab)
* mikel#664 - RSpec: with_html and with_text matchers. (zakkie)
* mikel#723 – IMAP: support `enable_starttls: true` for TLS upgrade on non-IMAPS/SSL servers. (doits)
* mikel#804 - Configurable SMTP open_timeout and read_timeout. (ankane)
* mikel#853 - `Mail::Message#set_sort_order` overrides the default message part sort order. (rafbm)
* mikel#856 - Added :logger delivery method. (zacholauson)
* mikel#650 - UTF-7 charset support. (johngrimes)
* mikel#900 - Support non-instance_eval builder API. Yield self to Mail.new if the provided block takes any arguments. (taavo)
* mikel#1065 - Require STARTTLS using :enable_starttls. (bk2204)
* mikel#1002 - Transcoding replaces invalid chars with "�" instead of discarding them. (kjg)
* mikel#1094 - Core extensions removal: Drop `String#at`, `from`, `last` and `is_utf8?` since they are no longer used by Mail internals. (metcalf)
* mikel#1095 - Core extensions removal: Drop `String#mb_chars`, `not_ascii_only?`, `constantize`, `first`, `to` to avoid monkey patching the standard library. (metcalf)
* mikel#1111 - Mail::Field.parse API which deprecates calling Mail::Field.new with unparsed header fields. (jeremy)
* mikel#1117 - Configurable POP3 read_timeout. (hspazio)

Performance:
* mikel#1059 - Switch from mime-types to mini_mime for a much smaller memory footprint. (SamSaffron)
* mikel#1119 - Speed up large attachment encoding by memoizing slow ASCII-only checks. (dalibor)

Compatibility:
* mikel#464 - Improve attachment filename detection by preferring Content-Disposition filename. (lawrencepit)
* mikel#535 - IMAP: fetch messages WITH IMAP FLAGS by passing a block with four args. (lawrencepit)
* mikel#558 - Parser: cope with unknown charsets in header fields by falling back to ASCII. (boesemar)
* mikel#655 - Sort attachments to the end of the parts list to work around email clients that may mistake a text attachment for the message body. (npickens)
* mikel#683 - SMTP: Work around Net::SMTP dot-stuffing bug with unterminated newlines on Ruby 1.8 and 1.9. (yyyc514)
* mikel#766 - No longer strip 'Subject: ' from legit subject lines. (grosser)
* mikel#982 – Faithfully preserve unfolded whitespace rather than collapsing to a single space. (jeremy)
* mikel#1103 – Support parsing UTF-8 headers. Implements RFC 6532. (jeremy)
* mikel#1106 – Limit message/rfc822 parts' transfer encoding per RFC 2046. (ahorek)
* mikel#1112 – Support Windows-1258 charset by parsing it as Windows-1252 in Ruby. (jeremy)
* mikel#1114 – Setting `mail.body = …` on a multipart message now adds a new text part instead of adding a raw MIME part. (jeremy)
* mikel#1159 – Parse emails with \n newlines so long as they have no binary content. (jeremy)

Bugs:
* mikel#539 - Fix that whitespace-only continued headers would be incorrectly parsed as the break between headers and body. (ConradIrwin)
* mikel#684 - Fix recursively fetching attachments from an embedded message/rfc822 part whose Content-Type header has additional parameters. (vongruenigen)
* mikel#689 - Fix Exim delivery method broken by mikel#477 in 2.5.4. (jethrogb)
* mikel#792 - Allow blank filenames in Content-Disposition field. (robinroestenburg)
* mikel#876 - Strip valid RFC-1342 separator characters between non-matching encoded-words (Caleb W. Corliss)
* mikel#895 - Fix that Mail::Message#add_file was adding a stray filename header. (kirikak2)
* mikel#923 – Fix decoding nested quotes around non-US-ASCII addresses. (averell23)
* mikel#978 - Fix for invalid chars being left in a string for invalid b_value from encoding. (kjg)
* mikel#996 - Fix that multipart/mixed emails with a delivery-status part could be interpreted as bounces. (kjg)
* mikel#998 - Fix header parameter parsing (such as attachment names) for values encoded with a blank charset or language code. (kjg)
* mikel#1000 - Fix header parameter parsing (such as attachment names) to transcode to UTF-8 (kjg)
* mikel#1020 - Don't set SMTP verify mode to nil when config was not provided. (jhass)
* mikel#1032 - Fix that comparing messages changed their raw Message-ID to their parsed message_id. (bobjflong)
* mikel#1074 - Fix that the first address in a list is dropped when a subsequent address has non-US-ASCII characters. (domininik)
* mikel#1107 - Fix Address#display_name and other formatting flip-flopping between encoded and decoded forms depending on whether #encoded or decoded was called last. (jeremy)
* mikel#1110 - Fix that Mail::Multibyte::Chars#initialize mutated its argument by calling force_encoding on it. (jeremy)
* mikel#1113 - Eliminate attachment corruption caused by CRLF conversion. (jeremy)
* mikel#1131 - Fix that Message#without_attachments! didn't parse the remaining parts. (jeremy)
* mikel#1019 - Fix b value encoder incorrectly splitting multibyte characters. (Kenneth-KT)
* mikel#1122 – Fix that tilde (~) shouldn't be escaped for Exim delivery. (Benabik)
* mikel#1157 - Fix base64 attachment transfer encoding being overridden by quoted-printable. (dalibor)

2.7.0.rc3

Toggle 2.7.0.rc3's commit message
Mail 2.7.0.rc3

Compatibility:
* mikel#1160 – Parse fixture emails with \n line endings. (jeremy)

Bugs:
* mikel#1122 – Fix that tilde (~) shouldn't be escaped for Exim delivery. (Benabik)

2.7.0.rc2

Toggle 2.7.0.rc2's commit message
Mail 2.7.0.rc2

Features:
* mikel#647 – IMAP: specify IMAP server search charset with Mail.find(search_charset: 'UTF-8'). (yalab)
* mikel#664 - RSpec: with_html and with_text matchers. (zakkie)
* mikel#723 – IMAP: support `enable_starttls: true` for TLS upgrade on non-IMAPS/SSL servers. (doits)
* mikel#856 - Added :logger delivery method. (zacholauson)
* mikel#900 - Support non-instance_eval builder API. Yield self to Mail.new if the provided block takes any arguments. (taavo)
* mikel#1111 - Mail::Field.parse API which deprecates calling Mail::Field.new with unparsed header fields. (jeremy)
* mikel#1117 - Configurable POP3 read_timeout. (hspazio)

Performance:
* mikel#1119 - Speed up large attachment encoding by memoizing slow ASCII-only checks. (dalibor)

Compatibility:
* mikel#535 - IMAP: fetch messages WITH IMAP FLAGS by passing a block with four args. (lawrencepit)
* mikel#558 - Parser: cope with unknown charsets in header fields by falling back to ASCII. (boesemar)
* mikel#683 - SMTP: Work around Net::SMTP dot-stuffing bug with unterminated newlines on Ruby 1.8 and 1.9. (yyyc514)
* mikel#766 - No longer strip 'Subject: ' from legit subject lines. (grosser)
* mikel#1103 – Support parsing UTF-8 headers. Implements RFC 6532. (jeremy)
* mikel#1106 – Limit message/rfc822 parts' transfer encoding per RFC 2046. (ahorek)
* mikel#1112 – Support Windows-1258 charset by parsing it as Windows-1252 in Ruby. (jeremy)
* mikel#1114 – Setting `mail.body = …` on a multipart message now adds a new text part instead of adding a raw MIME part. (jeremy)
* mikel#1159 – Parse emails with \n newlines so long as they have no binary content. (jeremy)

Bugs:
* mikel#684 - Fix recursively fetching attachments from an embedded message/rfc822 part whose Content-Type header has additional parameters. (vongruenigen)
* mikel#689 - Fix Exim delivery method broken by mikel#477 in 2.5.4. (jethrogb)
* mikel#792 - Allow blank filenames in Content-Disposition field. (robinroestenburg)
* mikel#876 - Fix that Mail::Message#add_file was adding a stray filename header (kirikak2)
* mikel#923 – Fix decoding nested quotes around non-US-ASCII addresses. (averell23)
* mikel#1107 - Fix Address#display_name and other formatting flip-flopping between encoded and decoded forms depending on whether #encoded or decoded was called last. (jeremy)
* mikel#1110 - Fix that Mail::Multibyte::Chars#initialize mutated its argument by calling force_encoding on it. (jeremy)
* mikel#1113 - Eliminate attachment corruption caused by CRLF conversion. (jeremy)
* mikel#1131 - Fix that Message#without_attachments! didn't parse the remaining parts. (jeremy)
* mikel#1019 - Fix b value encoder incorrectly splitting multibyte characters. (Kenneth-KT)
* mikel#1157 - Fix base64 attachment transfer encoding being overridden by quoted-printable. (dalibor)

2.7.0.rc1

Toggle 2.7.0.rc1's commit message
Mail 2.7.0.rc1

Features:
* mikel#804 - Configurable SMTP open_timeout and read_timeout. (ankane)
* mikel#853 - `Mail::Message#set_sort_order` overrides the default message part sort order. (rafbm)
* mikel#650 - UTF-7 charset support. (johngrimes)
* mikel#1065 - Require STARTTLS using :enable_starttls. (bk2204)
* mikel#1002 - Transcoding replaces invalid chars with "�" instead of discarding them. (kjg)
* mikel#1094 - Core extensions removal: Drop `String#at`, `from`, `last` and `is_utf8?` since they are no longer used by Mail internals. (metcalf)
* mikel#1095 - Core extensions removal: Drop `String#mb_chars`, `not_ascii_only?`, `constantize`, `first`, `to` to avoid monkey patching the standard library. (metcalf)

Performance:
* mikel#1059 - Switch from mime-types to mini_mime for a much smaller memory footprint. (SamSaffron)

Compatibility:
* mikel#464 - Improve attachment filename detection by preferring Content-Disposition filename. (lawrencepit)
* mikel#655 - Sort attachments to the end of the parts list to work around email clients that may mistake a text attachment for the message body. (npickens)
* mikel#982 – Faithfully preserve unfolded whitespace rather than collapsing to a single space. (jeremy)

Bugs:
* mikel#539 - Fix that whitespace-only continued headers would be incorrectly parsed as the break between headers and body. (ConradIrwin)
* mikel#876 - Strip valid RFC-1342 separator characters between non-matching encoded-words (Caleb W. Corliss)
* mikel#978 - Fix for invalid chars being left in a string for invalid b_value from encoding. (kjg)
* mikel#996 - Fix that multipart/mixed emails with a delivery-status part could be interpreted as bounces. (kjg)
* mikel#998 - Fix header parameter parsing (such as attachment names) for values encoded with a blank charset or language code. (kjg)
* mikel#1000 - Fix header parameter parsing (such as attachment names) to transcode to UTF-8 (kjg)
* mikel#1020 - Don't set SMTP verify mode to nil when config was not provided. (jhass)
* mikel#1032 - Fix that comparing messages changed their raw Message-ID to their parsed message_id. (bobjflong)
* mikel#1074 - Fix that the first address in a list is dropped when a subsequent address has non-US-ASCII characters. (domininik)

2.6.4

Toggle 2.6.4's commit message
== Version 2.6.4 - Wed Mar 23 08:16 -0700 2016 Jeremy Daer <jeremydae…

…r@gmail.com>

Features:
* mikel#772 - Normalize encoding matchers (grosser)
* mikel#775 - Avoid failed encodings / stop bad charsets early (grosser)
* mikel#782 – Make the gem compatible with Rubinius (robin850)
* mikel#865 - Allow a body with an invalid encoding to be round tripped (kjg)
* mikel#866 - Support decoding message bodies with non-Ruby-standard charsets (jeremy)
* mikel#868 - Use the Ruby19.charset_encoder when decoding message bodies (kjg)
* mikel#872 - Low-level option to include BCC field in the encoded message (grossadamm)
* mikel#901 - Allow mail.text_part = '…' and mail.html_part = '<p>…</p>' (taavo)
* mikel#924 - Matcher for having attachments (schepedw)

Performance:
* mikel#956 - Use native String#encode for CR/LF conversion (carsonreinke)
* mikel#970 - Support Ruby 2.3+ frozen string literals (twalpole)

Bugs:
* mikel#719 - Fix to not extract header content that looks like its field name (kjg)
* mikel#789 - Fix encoding collapsing not dealing with multiple encodings in 1 line (grosser)
* mikel#808 - Mail::Field correctly responds_to? the methods of its instantiated field (thegcat)
* mikel#849 - Handle calling Part#inline? when the Content-Disposition field couldn't be parsed (kjg)
* mikel#874 – Stay under 1000-char SMTP line length limits (pushrax)
* mikel#877 - Make Mail::Field == other take the field value into account (kjg)
* mikel#907 - Mail::ContentDispositionField should work with nil value (kjg)
* mikel#910 - Mail::Address should handle b_value_encoded local and domain parts (kjg)
* mikel#918 - Account for possibility of absent delivery-status headers (kjg)

2.6.3

Toggle 2.6.3's commit message
Version 2.6.3

2.6.2

Toggle 2.6.2's commit message
Version 2.6.2

2.6.1

Toggle 2.6.1's commit message
Version bump to 2.6.1

2.6.0

Toggle 2.6.0's commit message
Version bump to 2.6.0 RELEASE IT

2.5.4

Toggle 2.5.4's commit message
Update version to 2.5.4 and release